Atari.Org
Click Here
HomeNewsServicesForumsSupport

Talk Atari

Atari.Org Forums


16/32-Bit

8-Bits

Classics

Emulation

Jaguar

Lynx

Classic Consoles Forum 8-Bits Forum 16/32 Forum
Emulation Forum Jaguar Forum Lynx Forum
 
 Subject: RE: 2600 Troubleshooting question
Author: Eugene (pool-173-49-68-170.phlapa.fios.verizon.net)
Date:   10-15-2010 01:32

Brandon,

I used to work in an Atari Service Center in the early 80's. So I was nostalgically pleased to hear your 2600 rescue story.

We used to have similar problems even then. But the age of your new gaming pal possibly adds to a list of possible issues.

But I think that your contact degradation diagnosis is probably correct. Different game cartridges may have different number of active address lines, i.e. bigger games may have more address lines that are required to access the entire cartridge. It may be that one/some of those extra lines is not conducting well.

Now, to clean it, I would recommend using a cotton swab moistened with alcohol. Make sure not to leave lint. Or do a search for alternatives on the web. To do a more thorough job you may have to open the unit,- I can't remember.

Best of luck with your find.

 Topics Author  Date
  2600 Troubleshooting question new brandon 09-17-2010 04:06 
   RE: 2600 Troubleshooting question  Eugene 10-15-2010 01:32 
   RE: 2600 Troubleshooting question new Nathan 11-14-2010 16:11 
    RE: 2600 Troubleshooting question new Crystal 12-07-2010 00:58 

 Reply To This Message
 Your Name:
 Your Email:
 Subject:
 Human verification:   What's this?
               _    __     _ _     
 _ __  ___ _ _| |_ / _|___| (_)___ 
| '_ \/ _ \ '_|  _|  _/ _ \ | / _ \
| .__/\___/_|  \__|_| \___/_|_\___/
|_|                                
    



Copyright © 1997-2018 Atari.Org 
Atari is registered trademark of Infogrames