Atari.Org
Click Here
HomeNewsServicesForumsSupport

Talk Atari

Atari.Org Forums


16/32-Bit

8-Bits

Classics

Emulation

Jaguar

Lynx

Classic Consoles Forum 8-Bits Forum 16/32 Forum
Emulation Forum Jaguar Forum Lynx Forum
 
 Subject: Dual floppy drive units on STFM...?
Author: shalroth (cpc10-seac22-2-0-cust612.7-2.cable.virginm.net)
Date:   04-12-2014 04:27

Hi, Community!

I've just inherited a 520STfm with a bunch of software and Sound Master cartridge :-D

It's a stock 520 (with TOS 1.4) as far as I can tell, which makes it limited in usefulness but it runs all the fifty-or-so supplied games in 512K, and it's in beautiful cosmetic condition, so it would be a shame to part it out right away (the owner loved that machine and took very good care of it, so I'd feel bad breaking it down, at least right away).

Sadly, the floppy drive has failed - it spins and the heads move but I always get the Drive A: not responding message.

I'm fresh out of spare drives (although I could do a swap from another 520STfm but it's in ~/house/attic/deepstorage so I'd rather not dig it out.

I'm willing to buy a modified drive off ebay and customize the mechanics to accommodate the original eject button in the future, however, to soak-test the machine in the meantime, I was wondering...

I have a Cumana dual floppy drive which I used to use with my 520STm (lovely early machine, modded to 1MB and switchable TOS 1.0 / 2.06). I've used that unit in the past with my STe, but only one of the drives worked, which is to be expected (I don't remember which drive became B: however). Now - if I disconnect the internal drive from the 'fm, would both the drives in the dual unit function as they do on a driveless machine? Most of the games only boot from A: because of the boot sector loader etc. I have a single external drive too, but I suspect it's jumpered to be B:, so I wondered how the dual unit would behave in an ST with the internal drive disconnected.

I've read about the _nflops system variable, but when and how is this set? I don't think it's hard coded in TOS because TOS 2.06 only shipped with systems with one internal floppy drive, and yet the dual drive unit works correctly in TOS 2.06 on the STm!

I expect - and from my experience with the Spectre GCR Macintosh emulator I think this may be the case - that internal drive A: and external drive B: share the same set of wires. This being the case, then a machine with two external drives should be ELECTRICALLY identical to a machine with one internal and one external drive. Therefore, I would expect my proposed setup (with internal drive disconnected and a dual external drive connected) to function the same way as a system with an internal and external drive connected...

Has anyone tried this, or know if it should work? My theory falls apart when I consider the SF354 drives and how do they know which one should be A: when they're daisy-chained!

 Topics Author  Date
  Dual floppy drive units on STFM...? new shalroth 04-12-2014 04:27 
   RE: Dual floppy drive units on STFM...? new Paranoid 04-12-2014 21:49 
    RE: Dual floppy drive units on STFM...? new shalroth 04-13-2014 19:12 

 Reply To This Message
 Your Name:
 Your Email:
 Subject:
 Human verification:   What's this?
               _    __     _ _     
 _ __  ___ _ _| |_ / _|___| (_)___ 
| '_ \/ _ \ '_|  _|  _/ _ \ | / _ \
| .__/\___/_|  \__|_| \___/_|_\___/
|_|                                
    



Copyright © 1997-2019 Atari.Org 
Atari is registered trademark of Infogrames